How to order Bulk SMS credit
Issue
I wish to order to your Bulk SMS but I don’t know how to proceed with the order.
Symptoms
You are unsure on how to place the online order.
Cause
Confuse with the WHMCS (Billing System)
Workaround
You may place your new order by using below steps:
STEP 1: Go to http://billing.trio-mobile.com
* For LongCode Bulk SMS please click “Choose Another Category” and select “Bulk SMS LongCode”
STEP 2: Click Order Now on your preferred SMS package
* click Continue Shopping to add packages
STEP 3: Your details:
* If you are an existing client, kindly follow below steps:
- Under Existing Client Login, enter your Username and Password.
- Reset your billing Password at http://billing.trio-mobile.com/pwreset.php , if you’ve forgotten your login password.
- Please note that, Trio Mobile Billing Login and CloudSMS login are two different systems with different web page. Thus, login credentials would be different (except that its been set same earlier)
* If you are a new client, please fill in your details
STEP 4: Choose Payment Method, add Notes and tick “I have read and agree to the Terms of Service”
STEP 5: Click Complete Order
Additional Information
-Kindly choose “FPX Online Banking” payment methods for e-banking funds transfer such as M2u, Pbe, CIMB click, RHB now and etc.
-The top up notification email will be sent to your Billing Registered Email immediately once the payment has been made and invoice has converted to PAID.
-Other payment method please refer to https://www.trio-mobile.com/payment-method/